PAT_甲级_1078

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzc842650834/article/details/88093876

1078 Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​ ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

单引号输入了两个字符,找了半天才找到的bug

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string.h>
using namespace std;
int HashTable[10020];
int flag[10020];
vector<int> arr;
int Is_Prime(int a)
{
    if (a <= 1) {
        return 0;
    }
    int temp = (int)(sqrt(a));
    for (int i = 2; i <= temp; i++) {
        if (a % i == 0) {
            return 0;
        }
    }
    return 1;
}
int main()
{
    memset(HashTable, 0, sizeof(HashTable));
    memset(flag, 0, sizeof(flag));
    int m, n;
    int temp;
    cin >> m >> n;
    while (!Is_Prime(m)) {
        m++;
    }
    for (int i = 0; i < n; i++) {
        cin >> temp;
        int flag_temp = 0;
        for (int j = 0; j < m; j++) {
            int temp_2 = (temp + j * j) % m;
            if (flag[temp_2] == 0) {
                HashTable[i] = temp_2;
                flag[temp_2] = 1;
                flag_temp = 1;
                break;
            }
        }
        if (flag_temp == 0) {
            HashTable[i] = -1;
        }
    }
    for (int i = 1; i < n; i++) {
        if (HashTable[i] != -1) {
            cout << ' ' << HashTable[i];
        } else {
            cout << " -";
        }
    }
    cout << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzc842650834/article/details/88093876