POJ - 3628 Bookshelf 2 【0-1背包】

版权声明:记笔记~~~ https://blog.csdn.net/weixin_42765557/article/details/88049127

 题目链接:                                                           Bookshelf 2

Time Limit: 1000MS   Memory Limit: 65536K

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

解题思路

这题数据规模很小,可以用二进制枚举头牛选或不选,然后取最小差;也可以用01背包dp来做

二进制枚举 47ms

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	int N,H,h[21];
	cin >> N >> H;
	for(int i=1;i<=N;i++) 
		cin >> h[i];
		
	int tot = pow(2,N);
	int sum,Min=0x3f3f3f3f;
	bool flag;
	for(int i=1;i<=tot;i++) {
		sum = 0;
		flag = false;
		for(int j=1;j<=N;j++) {
			if(i & (1 << (j-1))) 
				sum += h[j];
		}
		if(sum == H) {
			cout << "0\n";
			break;
		}
		if(sum > H) {
			Min = Min<sum ? Min:sum;
		}
	}
	cout << Min-H << endl;
}

01背包dp 0ms

所有牛的高度为sum,架高度H,只要求(rare = )sum-H 这个容量里最多容纳多高的牛即可。rare最大,则sum - rare - H(即高度差)最小。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
	int N,H,h[21],sum=0;
	cin >> N >> H;
	for(int i=1;i<=N;i++) {
		cin >> h[i];
		sum += h[i];
	}
	
	int rare = sum - H;
	int Max[rare+1];
	memset(Max,0,sizeof Max);
	for(int i=1;i<=N;i++)
		for(int j=rare;j>=h[i];j--)
			Max[j] = max(Max[j],Max[j-h[i]]+h[i]);    //一位数组空间优化 
			
	cout << (sum - Max[rare]) - H;
		 
} 

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/88049127
今日推荐