Bookshelf 2

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal ‘excess’ height between the optimal stack of cows and the bookshelf.

Input

  • Line 1: Two space-separated integers: N and B
  • Lines 2…N+1: Line i+1 contains a single integer: Hi

Output

  • Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input
5 16
3
1
3
5
6
Sample Output
1

题意:
有N头奶牛,给出其各自身高hi,一书架高B,奶牛们需要叠在一起并达到不小于B的高度,求奶牛总高度与B差值的min值。

思路:背包问题
1 确定可能的最大高度sum。就是全部的a加起来的高度

2 依据动态规划法。求解1到最大高度sum之间的可能解

3 找到比B(书架高度)的最低高度。可能和B一致。

在这里插入代码片
#include"cstdio"
#include"cstring"
#include"algorithm"
#include"iostream"
#include"cmath"
using namespace std;
int dp[1500000],a[4000];
int main()
{
	int n,m;
	while(~scanf("%d %d",&n,&m))
	{
		long long sum=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			for(int j=sum;j>=a[i];j--)
			{
				dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
			}
		}
		for(int i=0;i<=sum;i++)
		{
			if(dp[i]>=m)
			{
				printf("%d\n",dp[i]-m);
				break;
			}	
		}
		///printf("%d\n",dp[n]-m);
	}
	return 0;
}


发布了76 篇原创文章 · 获赞 1 · 访问量 2772

猜你喜欢

转载自blog.csdn.net/weixin_44824383/article/details/102939914