B - Bookshelf 2 POJ - 3628 dp

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

每一道dp都是让人想骂人的题呢。

题意:有n个大象,有一个暑假高度为B,现在问你把大象叠起来的高度与书架的高度差最小是多少。

解题关键在于:dp[j] 代表了不超过j的,最大的,大象能叠的高度。!!!这里不能直接弄高度差。

首先得把大象高度总和求出来。

然后dp[j]=max(dp[j],dp[j-a[i]]+a[i]);

#include"stdio.h"
#include"algorithm"
#include"string.h"
using namespace std;
int dp[1300000];//取前i个 不超过j 最大高度 
long long sum ;
int main()
{
	int n,m;
	
	int a[4000],b[4000]; 
	while(~scanf("%d %d",&n,&m))
	{
		memset(dp,0,sizeof(dp));
		sum = 0;
		for(int i = 1;i <= n;i ++)
		{
			scanf("%d",&a[i]);
			sum += a[i];
		}

		for(int i = 1;i <= n; i ++)
		{
			for(int j = sum;j >=a[i];j --)
			{
				dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
			}
		}

		for(int i = 0;i<= sum;i ++)
		{
			if(dp[i] >= m)
			{
				printf("%d\n",dp[i]-m);
				break;
			}
		}
	}
	return 0;
}
发布了58 篇原创文章 · 获赞 20 · 访问量 5221

猜你喜欢

转载自blog.csdn.net/qq_41658124/article/details/102709342