HDU-1179 匈牙利算法

版权声明:本文为博主原创文章,若需要引用、转载,只需注明来源及原文链接,若有错误,欢迎纠正。 https://blog.csdn.net/u014137295/article/details/88069192

Input
There are several cases. For each case, there is two integers N and M in the first line,which mean there is N wizards and M wands(0 < N <= M <= 100).
Then M lines contain the choices of each wand.The first integer in i+1th line is Ki,and after these there are Ki integers Bi,j which are the wizards who fit that wand. (0<=Ki<=N,1<=Bi,j<=N)
Output
Only one integer,shows how many wands Ollivander can sell.
Sample Input
3 4
3 1 2 3
1 1
1 1
0
Sample Output
2
Hint
Wand 1 fits everyone, Wand 2,3 only fit the first wizard,and Wand 4 does not fit anyone. So Ollivanders can sell two wands:
sell Wand 1 to Wizard 2 and Wand 2 to Wizard 1,or sell Wand 1 to Wizard 3 and Wand 3 to Wizard 1 ,or some other cases. But
he cannot sell 3 wands because no 3 wands just fit 3 wizards.
代码:

#include<bits/stdc++.h>
#define maxn 103
using namespace std;
inline int read(){
	int x=0,f=1;char ch=getchar();
	while(ch>'9'||ch<'0'){if(ch=='-')f=-1;ch=getchar();}
	while(ch>='0'&&ch<='9'){x=(x<<3)+(x<<1)+ch-'0';ch=getchar();}
	return x*f;
}
int n,m,line[maxn][maxn],used[maxn],nxt[maxn];
int Find(int x){
	for(int i=1;i<=m;++i)
		if(line[x][i]&&!used[i]){
			used[i]=1;
			if(nxt[i]==0||Find(nxt[i])){
				nxt[i]=x;
				return 1;
			}
		}
	return 0;
}
int match(){
	int sum=0;
	for(int i=1;i<=n;++i){
		memset(used,0,sizeof(used));
		if(Find(i))++sum;
	}
	return sum;
}
int main(){
	while(~scanf("%d%d",&n,&m)){
		memset(line,0,sizeof(line));
		memset(nxt,0,sizeof(nxt));
		for(int i=1;i<=m;++i){
			int u=read();
			while(u--)line[read()][i]=1;
		}
		printf("%d\n",match());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/u014137295/article/details/88069192
今日推荐