hdu1069 测猴子智力(改成最大上升子序列)

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:给你各种长方体,给你三条边的长,然后让你叠加,叠加的时候上面一块的长和宽分别要小于下面一块的长和宽,每种长方体都有无限个,但其实最多只考虑六个,因为长和宽重复的话只取一个即可。三条边的情况有三种情况,三条边都相等,其中只有两条边相等(该情况又能分成三种),和条边都不相等。
题解:还记得最大上升子序列吗,是不可以先拿前面(比如是5)的再拿后面的(比如10),10>5但子序列的顺序是不能从前往后的,所以在该题给它按宽从小到大排序,这样只能是后面的长方体放前面上面,而不能前面的放后面的上面,这样就变成最大上升子序列了。(只是最大上升子序列是判断后面的数要大于前面的,而我们这里是根据后面的长和宽分别要小于前面的,条件改一下即可)

ac代码

#include<iostream>       
#include<cstdlib>      
#include<cstdio> 
#include<cstring>      
#include<cmath>           
#include<string>      
#include<cstdlib>      
#include<iomanip>      
#include<vector>      
#include<list>      
#include<map>      
#include<queue>    
#include<algorithm>
using namespace std;
const int N = 185;

struct node
{
	int  x, y, h,dp;
}p[N];//dp储存放到该长方体时的最大高度,初始还未叠加,暂时为各个长方体的高。
int cmp(node s1, node s2)
{
	return s1.x < s2.x;
}
int main()
{
	int n, k = 0, a, b, c,sum=1;
	while (cin >> n,n)
	{
		k = 0;
		for (int i = 0; i < n; i++)
		{
			scanf("%d%d%d", &a, &b, &c);
			if (a == b == c)
			{
				p[k].h = p[k].dp = p[k].x = p[k].y = a; k++;
			}
			else if (a == b && b != c)
			{
				p[k].x = p[k].y = a; p[k].dp = p[k].h = c; k++;
				p[k].dp = p[k].h = a; p[k].x = b; p[k].y = c; k++;
				p[k].dp = p[k].h = a; p[k].x = c; p[k].y = b; k++;
			}
			else if (a != b && b == c)
			{
				p[k].x = b; p[k].y = a; p[k].dp = p[k].h = c; k++;
				p[k].dp = p[k].h = a; p[k].x = p[k].y = b; k++;
				p[k].dp = p[k].h = c; p[k].x = a; p[k].y = b; k++;
			}
			else if (c != b && a == c)
			{
				p[k].x = b; p[k].y = a; p[k].dp = p[k].h = c; k++;
				p[k].dp = p[k].h = b; p[k].x = p[k].y = c; k++;
				p[k].dp = p[k].h = c; p[k].x = a; p[k].y = b; k++;
			}
			else {
				p[k].dp = p[k].h = a; p[k].x = b; p[k].y = c; k++;
				p[k].dp = p[k].h = a; p[k].x = c; p[k].y = b; k++;
				p[k].x = b; p[k].y = a; p[k].dp = p[k].h = c; k++;
				p[k].x = a; p[k].y = b; p[k].dp = p[k].h = c; k++;
				p[k].dp = p[k].h = b; p[k].x = a; p[k].y = c; k++;
				p[k].dp = p[k].h = b; p[k].x = c; p[k].y = a; k++;
			}
		}
		sort(p, p + k, cmp); int Max = p[0].dp;
		for (int i = 1; i < k; i++)
		{
			for (int j = 0; j < i; j++)
			{
				if (p[i].x > p[j].x&&p[i].y > p[j].y)
					p[i].dp = max(p[i].dp, p[j].dp + p[i].h);//最大上升子序列的公式

			}Max = max(Max, p[i].dp);
		}cout << "Case " << sum << ":" << " maximum height = " << Max << endl;
		sum++;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43965698/article/details/87857910