A + B Problem II(高精度运算)

Click here to have a try
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author

Ignatius.L

问题分析:

与A+B-problem一样主要是计算两个值的加法,但不同的是要注意注意到输入的两个加数可以很大,结果也可以很大,那么用一般的加法去写程序似乎就不行了。

个人感想:

ACM周赛题能被我脱了五天才重新看也是没谁了,然后就是去找一下分析,在自己做一些,就行啦啦啦啦啦啦啦啦啦啦啦啦。回归正题,考虑到这是高精度运算,用一般的加法程序是必定是AC不了的,看了分析之后可以考虑利用两个数组来存放输入的两段数字,然后考虑两个数组里的每一个对应的元素相加,但别忘了考虑当加起来大于等于10时的情况,于是为了方便对应相加,可以考虑先把输入的数倒叙输入另外的数组,这样比如a[0]与b[0]就是对应的数了,就不用去考虑在输入的数字不同长度时的对应问题了,当然不搞逆序也行,不过就要去考虑当相加之后的数比输入两个数都大的情况了(会比较麻烦,不过也是可以的),只要依旧时别忘了相加大于等于10的情况。

话不多说,代码附上:

VJ通过的代码如下:

#include <iostream>
#include<algorithm>
using namespace std;
int main()
{
	char a[1000], b[1000]; 
	int  a1[1000], b1[1000], c[1100];
	int T, k, y;
	cin >> T;
	y = T;
		for (k = 1;k <= T;k++)
		{
			int i, j, p, l;
			memset(a1, 0, sizeof(a1));
			memset(b1, 0, sizeof(b1));
			memset(c, 0, sizeof(c));
			cin >> a >> b;
			int len1 = strlen(a);
			int len2 = strlen(b);
			for (i = 0;i < len1;i++)    a1[i] = a[len1 - i - 1] - '0';
			for (j = 0;j < len2;j++)    b1[j] = b[len2 - j - 1] - '0';
			for (p = 0;p < min(len1,len2);p++)
			{
				c[p] = a1[p] + b1[p] + c[p];
				if (c[p] >= 10)
				{
					c[p + 1] = 1;
					c[p] = c[p] - 10;
				}
			}
			for (l = min(len1, len2);l < max(len1, len2);l++)
			{
				if (len1 > len2)  c[l] = a1[l] + c[l];
				if (len1 < len2) c[l] = b1[l] + c[l];
			}
			cout << "Case " << k << ':' << endl;
			cout << a << " " << '+' << " " << b << " " << '=' << " ";
			for (int i = max(len1, len2) - 1;i >= 0;i--)
				cout << c[i];
			if (k != T)
				cout << endl << endl;
			else
				cout << endl;
			//不知道为什么如果格式输出换成下面的就通不过,要是有大神指导一下迷津就太棒了,嘻嘻
			//printf("Case %d :\n", k);
			//for (int i = len1-1;i >= 0;i--) printf("%d", a1[i]);
			//printf(" + ");
			//for (int i = len2-1;i >= 0;i--) printf("%d", b1[i]);
			//printf(" = ");
			//for (int q = max(len1,len2)-1;q >=0;q--)  printf("%d", c[q]);
			//if (k != T) printf("\n\n");
			//else printf("\n");
		}
}

猜你喜欢

转载自blog.csdn.net/weixin_43697280/article/details/85160614
今日推荐