高精度 模拟A - A + B Problem II大数加法(寒假集训)

题目要求
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
大数加法因为数据过大而不能存储在long long 中,以字符串来带入,将每一位的字符串-‘0’即可得到该位置的数字。利用两个数组来存放输入的两段数字,然后两个数组里的每一个对应的数字相加,还要判断大于10进位的条件。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<math.h> 
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
	
	int n,t;
	cin>>n;
	for(t=1;t<=n;t++)
	{
		char a[1111],b[1111];
		int c[1111];
		cin>>a>>b;
		int i,j,k=0;
		int m=0;
		for(i=strlen(a)-1,j=strlen(b)-1;i>=0&&j>=0;i--,j--)
		{
			int p=(a[i]-'0')+(b[j]-'0')+m;
			m=p/10;
			c[k++]=p%10;
		}
		while(i>=0)
		{
			int p=(a[i]-'0')+m;
			m=p/10;
			c[k++]=p%10;
			i--;
		}
		while(j>=0)
		{
			int p=(b[j]-'0')+m;
			m=p/10;
			c[k++]=p%10;
			j--;	
		}
		if(m)
		{
			c[k++]=m;
		}
		printf("Case %d:\n",t);
		cout<<a<<' '<<'+'<<' '<<b<<' '<<'='<<' ';
		for(int i=k-1;i>=0;i--)
			cout<<c[i];
		printf("\n"); 
		if(t!=n)printf("\n"); 
	}
	return 0;
}
发布了38 篇原创文章 · 获赞 27 · 访问量 3165

猜你喜欢

转载自blog.csdn.net/qq_45891413/article/details/105302822
今日推荐