SDUTOJ3344数据结构实验之二叉树五:层序遍历

版权声明:iQXQZX https://blog.csdn.net/Cherishlife_/article/details/84984829

数据结构实验之二叉树五:层序遍历

https://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Contest/contestproblem/cid/2711/pid/3344

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

 输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output

 输出二叉树的层次遍历序列。

Sample Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

Sample Output

abcdefg
xnuli

Hint

 

Source

xam

#include <bits/stdc++.h>
using namespace std;
struct tree
{
    char c;
    tree *l, *r;
};
int cnt;
char s[100];
tree *creat(tree *root) // 构建二叉树
{
    if (s[cnt] == ',')
    {
        cnt++;
        return NULL;
    }
    root = new tree;
    root->c = s[cnt++];
    root->l = creat(root->l);
    root->r = creat(root->r);
    return root;
}
void show(tree *root) // 层序遍历二叉树 // 通过队列实现
{
    queue<tree *> q;
    if (root)
        q.push(root);
    while (!q.empty())
    {
        root = q.front();
        q.pop();
        if (root)
        {
            cout << root->c;
            q.push(root->l);
            q.push(root->r);
        }
    }
}
int main()
{
    int n;
    // char s[100];
    cin >> n;
    while (n--)
    {
        tree *tree;
        cin >> s;
        cnt = 0;
        tree = creat(tree);
        show(tree);
        cout << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Cherishlife_/article/details/84984829