数据结构实验之二叉树五:层序遍历

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

 输入数据有多行,第一行是一个整数 t (t<1000) ,代表有 t 行测试数据。每行是一个长度小于 50 个字符的字符串。

Output

 输出二叉树的层次遍历序列。

Sample Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

Sample Output

abcdefg
xnuli
#include <bits/stdc++.h>
using namespace std;
char a[55];
int l;
typedef struct tnode
{
    char data;
    struct tnode *lc,*rc;
}*tree;

tree create()
{
    tree t;
    char c;
    c=a[l++];
    if(c==','){
        t=NULL;
    }
    else {
        t=new(tnode);
        t->data=c;
        t->lc=create();
        t->rc=create();
    }
    return t;
}

void cengxu(tree t)
{
    tree temp[100];
    int in=0,out=0;
    temp[in++]=t;
    while(in>out){
        if(temp[out]){
            cout<<temp[out]->data;
            temp[in++]=temp[out]->lc;
            temp[in++]=temp[out]->rc;
        }
        out++;
    }

}
int main()
{
    int n;
    cin>>n;
    while(n--){
        tree t;
        cin>>a;
        l=0;
        t=create();
        cengxu(t);
        cout<<endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/wywysun/article/details/81040944