Java 分解质因数

问题描述

  求出区间[a,b]中所有整数的质因数分解。

输入格式

  输入两个整数a,b。

输出格式

  每行输出一个数的分解,形如k=a1*a2*a3...(a1<=a2<=a3...,k也是从小到大的)(具体可看样例)

样例输入

3 10

样例输出

3=3
4=2*2
5=5
6=2*3
7=7
8=2*2*2
9=3*3
10=2*5

提示

  先筛出所有素数,然后再分解。

数据规模和约定

  2<=a<=b<=10000

代码:

import java.util.Scanner;

public class Test {
    public static boolean sushu(int x) {
        for (int i = 2; i < x; i++) {
            if (x % i == 0) {
                return false;
            }
        }
        return true;
    }
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int a = sc.nextInt();
        int b = sc.nextInt();
        for (int i = a; i <= b; i++) {
            System.out.print(i + "=");
            int temp = i;
            while (sushu(temp)==false){
                for (int j = 2; j < temp; j++){
                    if (temp % j == 0) {
                        System.out.print(j+"*");
                        temp = temp/j;
                    }
                }
            }
            System.out.print(temp);
            System.out.println();
        }
    }
}

猜你喜欢

转载自blog.csdn.net/a215012954/article/details/86561137