小根堆-Buy and Resell -HDU-6438

The Power Cube is used as a stash of Exotic Power. There are nn cities numbered 1,2,…,n1,2,…,n where allowed to trade it. The trading price of the Power Cube in the ii-th city is aiai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the ii-th city and choose exactly one of the following three options on the ii-th day: 

1. spend aiai dollars to buy a Power Cube 
2. resell a Power Cube and get aiai dollars if he has at least one Power Cube 
3. do nothing 

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the nn cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning. 

Input

There are multiple test cases. The first line of input contains a positive integer TT(T≤250T≤250), indicating the number of test cases. For each test case: 
The first line has an integer nn. (1≤n≤1051≤n≤105) 
The second line has nn integers a1,a2,…,ana1,a2,…,an where aiai means the trading price (buy or sell) of the Power Cube in the ii-th city. (1≤ai≤1091≤ai≤109) 
It is guaranteed that the sum of all nn is no more than 5×1055×105. 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output

16 4
5 2
0 0


        
  

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. 
         
  profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. 
         
  profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. 
         
  profit = 0

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
    int v,st;
    node(){}
    node(int v,int st):v(v),st(st){}
    friend bool operator<(node n1,node n2)
    {
        if(n2.v < n1.v)
            return true;
        if(n2.v == n1.v && n2.st < n1.st)
            return true;
        return false;
    }
}; 
priority_queue<node> qu;
int t,n,v,cnt;
long long ans;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        ans = cnt = 0;
        while(!qu.empty())
            qu.pop();
        while(n--)
        {
            scanf("%d",&v);
            if(!qu.empty() && qu.top().v < v)
            {
                node nn = qu.top();
                qu.pop();
                ans += v - nn.v;
                if(nn.st == 1)
                    cnt += 2;
                qu.push(node(v,1));
                qu.push(node(v,0));
            }
            else
                qu.push(node(v,1));
        }
        printf("%lld %d\n",ans,cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xing_mo/article/details/82119654