HDU 6438 Buy and Resell【贪心】

http://acm.hdu.edu.cn/showproblem.php?pid=6438

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

 

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

Sample Output

 

16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

题意:
在某一个点有三种操作
花ai买一个
卖一个获得ai(如果有存货)
不操作
可以手里有多个存货,假如开始有无限的钱
最大利润时最小的交换次数

分析:

贪心,尽量的卖,查看卖是否是最优的,否则重新买回

优化代码:

#include<bits/stdc++.h>
using namespace std;
struct sell
{
    long long int  val;
    bool operator<(const sell &aa)const
    {
        return val>aa.val;
    }
};
priority_queue<sell>Sell,REsell;///Sell 表示已经买了的(假买)  REsell表示卖了的(假卖)
long long int ans,num;
int main()
{
    long long t,i,j,n,x,now,next;
    sell tt;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&n);
        while(!Sell.empty())
        {
            Sell.pop();
        }
        while(!REsell.empty())
        {
            REsell.pop();
        }
        ans=num=0;
        for(i=0;i<n;i++)
        {
            scanf("%lld",&x);///新加的

            if(!REsell.empty()){
                now=REsell.top().val;
                if(!Sell.empty()&&Sell.top().val<min(x,now))///一定可以卖(目前还没有卖的的最小值,比已经卖了的最小值小,或者比新加入x的小)
                {
                    num++;
                    ans+=x;
                    tt.val=x;
                    REsell.push(tt);
                    Sell.pop();
                }
                else
                if(now<x)///如果这时存在卖了的最小值比当前加入的小,这说明之前卖的不值,之前的now应该选择买,所以这个点卖出去,此时买卖次数不变,之前卖的不足以买回来。必须在第一步后面
                {
                    REsell.pop();
                    tt.val=now;
                    Sell.push(tt);
                    ans-=2*now;///将卖了的转换成买
                    ans+=x;
                    tt.val=x;
                    REsell.push(tt);
                }
                else ///只能将这一个物品买入
                {
                    tt.val=x;
                    Sell.push(tt);
                    ans-=x;
                }
            }
            else
            if(!Sell.empty()&&Sell.top().val<x)///可以卖,此时新加的比已经买了的最小值还要大
            {
                num++;
                ans+=x;
                tt.val=x;
                REsell.push(tt);
                Sell.pop();
            }
            else///不能卖,就只能选择买
            {
                tt.val=x;
                Sell.push(tt);
                ans-=x;
                //printf("4ans=%lld num=%lld\n",ans,num);
            }

        }
        while(!Sell.empty())///没有卖出去的,以原价卖出
        {
            ans+=Sell.top().val;
            Sell.pop();
        }
        printf("%lld %lld\n",ans,num*2);
    }
}

猜你喜欢

转载自blog.csdn.net/lml11111/article/details/82055615