A - Buy and Resell HDU - 6438 2018-ccpc -csdn博客

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

  1. spend ai dollars to buy a Power Cube
  2. resell a Power Cube and get ai dollars if he has at least one Power Cube
  3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.
Input
There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.
Output
For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.
Sample Input
3
4
1 2 10 9
5
9 5 9 10 5
2
2 1
Sample Output
16 4
5 2
0 0

Hint
In the first case, he will buy in 1, 2 and resell in 3, 4.

profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4.

profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing.

profit = 0

  • 题意:一个商人从左到右做买卖,没到一个城市,可以选择买入一件商品后者卖出一件商品(前提是自己有),求最大利润和最先进入的城市

  • 解题思路:
    在每一个点上进行卖出操作,将val[i]放进优先级队列q(已负数形式加入相当于最小的在最上面),则每一次我卖出的收益为val[i]-q.top()
       当前面没有比这个点价值小的点时我会卖出这个点,这样存入的点要买入都会先卖出一次然后再遇到更大的价值时再买入一次,所以每个点存入两次
       这样我可以求出所得的最大利益
       现在求最大利益下的买入卖出次数,对每个push进队列的数我们打一个标记,1代表第一次卖出这个数,0代表第二次买入这个数
       由上诉分析可以得到:当我买入一个数时,也就代表了我进行了买入卖出一共两次操作

这个题很好的一道题,不过我是在事后看了别人的题解在弄明白了思路,然后这个代码哪怕是知道思路后也是一个非常精简的代码,是我看了很多题解后找到的一个非常好的代码,然后在这里分享一下
参考的文章

#include<bits/stdc++.h>
#define endl '\n'
#define pb push_back
#define mk make_pair
#define _ ios::sync_with_stdio(false)
bool SUBMIT = 1;
typedef long long ll;
using namespace std;
const double PI = acos(-1);
const int inf = 5*1e5+100;
priority_queue<pair<ll,ll> >q;
int main()
{
    if(!SUBMIT)freopen("i.txt","r",stdin);else _;
    int t;cin>>t;
    while(t--)
    {
        int n;cin>>n;
        while(!q.empty())q.pop();
        ll ans=0,cnt=0;
        ll x;
        for(int i=0;i<n;i++)
        {
            cin>>x;
            q.push(mk(-x,1));q.push(mk(-x,0));
            ans+=x+q.top().first;
            if(!q.top().second){
                cnt+=2;
            }
            q.pop();
            //cout<<ans<<" "<<cnt<<endl;
        }
        cout<<ans<<" "<<cnt<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38701476/article/details/82355005
今日推荐