HDU6438 Buy and Resell 贪心+堆

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1784    Accepted Submission(s): 630


 

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i -th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i -th city and choose exactly one of the following three options on the i -th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250 ), indicating the number of test cases. For each test case:
The first line has an integer n . (1≤n≤105 )
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i -th city. (1≤ai≤109 )
It is guaranteed that the sum of all n is no more than 5×105 .

 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

 

Sample Input

 

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

 

Sample Output

 
16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0  

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

参照:

https://blog.csdn.net/qq_39599067/article/details/82056382

https://blog.csdn.net/CURRYWANG97/article/details/82055044

#include<bits/stdc++.h>
#define mme(a,b) memset((a),(b),sizeof((a)))
using namespace std;
typedef long long LL;
const int INF = 0x3f3f3f3f;
struct forma
{
  int first,second;
  friend bool operator < (forma a,forma b){
    if(a.first!=b.first)
      return a.first<b.first; //从小到大,第一个top为最小值
    else
      return a.second<b.second;
  }
};
int main() {
  int tim;
  int n;
  scanf("%d", &tim);
  while(tim--){
  scanf("%d",&n);
    priority_queue<forma >q;
    LL ans = 0;
    int tot = 0;
    for(int i = 0, x; i < n; ++i){
      scanf("%d",&x);
      q.push((forma){-x,1});//买入
      q.push((forma){-x,2});//卖出
      LL tmp=x+q.top().first;
      if(q.top().second == 1)tot+=2;//对于实际交易,买入一次必对应一次卖出
      ans += tmp;
      q.pop(); 
    }
    printf("%lld %d\n",ans,tot);
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41548233/article/details/82145723
今日推荐