HDU - 6438 Buy and Resell(贪心)

版权声明:本文为博主原创文章,转载请附上注明就行_(:з」∠)_。 https://blog.csdn.net/vocaloid01/article/details/82079251

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n

cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

Input

There are multiple test cases. The first line of input contains a positive integer T

(T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output

16 4
5 2
0 0  

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. 
         
  profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. 
         
  profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. 
         
  profit = 0

题解:代码不长,直接看代码理解更快更容易。

代码:

#include <cstdio>
#include <queue>

using namespace std;

const int MAXN = 100010;

struct D
{
    int v,id;
    D(){}
    D(int _v,int _id):v(_v),id(_id){}
};

struct cmp
{
    bool operator ()(struct D a,struct D b)
	{
        if(a.v == b.v)return a.id < b.id;
        return a.v > b.v;
    }
};

int board[MAXN];

int main()
{
	int T,N;
	scanf("%d",&T);
	while(T--)
	{
		priority_queue<D,vector<D>,cmp> Q;
		scanf("%d",&N);
		int x;
		long long sum = 0;
		int time = 0;
		D t;
		for(int i=1 ; i<=N ; i++)
		{
			scanf("%d",&x);
			if(Q.empty() || Q.top().v>=x)Q.push(D(x,0));
			else 
			{
				t = Q.top();
				Q.pop();
				sum += x - t.v;
				if(t.id)
				{
					Q.push(D(t.v,0));
					Q.push(D(x,1));
				}
				else 
				{
					Q.push(D(x,1));
					++time;
				}
			}
		}
		printf("%lld %d\n",sum,time*2);
	}

    return 0;
}

猜你喜欢

转载自blog.csdn.net/vocaloid01/article/details/82079251