1004 Counting Leaves(DFS, vector v[100])

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/LightInDarkness/article/details/84888374

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

Analyze:

    As far as I'm concerned, the most import thing is to find a appropriate data structure to build a family tree. Maybe it's not a good idea to use 'struct' because you can not ascertain how many children does a node have. Honestly it bothers me a lot. Originally I had intended to use nested vector, but it doesn't work apparently. However, I draw on the experience of the code on the Internet. The girl use vector like an array, she defines it like this: vector<int> v[100], so that you can save the information of each node(their children's index). This form can be realizable by other struct, but it would be more difficult. When you can build a family tree, it's easy to know how many leaf-node in each level. I apply DFS(Depth-First-Search) algorithm to this problem.

#include<iostream>
#include<vector>

using namespace std;

vector<int> v[100];
int record[100];

void CheckNode(int p, int depth){
	if(v[p].size() > 0){
		for(int i = 0; i < v[p].size(); i++)
			CheckNode(v[p][i], depth + 1);
	}else{
		record[depth]++;
	}
}

int main(){
	int N, M, index, K, node, cnt = 0;
	cin >> N >> M;
	for(int i = 0; i < M; i++){
		cin >> index >> K;
		for(int j = 0; j < K; j++){
			cin >> node;
			v[index].push_back(node);
		}
	}
	CheckNode(1, 1);
	for(int i = 1; cnt != N - M; i++){
		if(i == 1) cout << record[i];
		else cout << ' ' << record[i];
		cnt += record[i];
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/LightInDarkness/article/details/84888374
今日推荐