【PAT - 甲级1004】Counting Leaves (30分) (dfs,递归)

题干:

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题目大意:

给你一棵树,有N个节点和M个非叶子结点(N,M<100),已知所有非叶子节点的编号和对应的孩子节点,让你输出每一个深度有多少个叶子节点。

解题报告:

按照输入建树,然后直接dfs预处理深度,On遍历得出答案即可。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;

vector<int> tr[222];
int dep[222],ok[222],ans[MAX],n,m;
void dfs(int cur,int fa) {
	dep[cur] = dep[fa] + 1;
	int up = tr[cur].size();
	for(int i = 0; i<up; i++) {
		int v = tr[cur][i];
		dfs(v,cur);
	}
}
int main()
{
	cin>>n>>m;
	for(int tmp,id,k,i = 1; i<=m; i++) {
		scanf("%d%d",&id,&k);
		ok[id] = 1;
		for(int j = 1; j<=k; j++) {
			scanf("%d",&tmp); tr[id].push_back(tmp);
		}
	}
	dfs(1,0);
	int mx = 0;
	for(int i = 1; i<=n; i++) {
		mx = max(mx,dep[i]);
		if(ok[i] == 1) continue;
		ans[dep[i]]++;
		
	}
	for(int i = 1; i<=mx; i++) {
		printf("%d%c",ans[i],i == mx ? '\n' : ' '); 
	}
	return 0;
}
发布了1106 篇原创文章 · 获赞 122 · 访问量 23万+

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/104123967