C++ Pat甲级1004 Counting Leaves (30 分)树+vector+dfs

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing  0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

输入:总节点数n,非叶节点数 m

       m行:给定的非叶节点 ID,非叶节点孩子节点的个数 k, 每个孩子的 ID[1],.........ID[k]

输出:每一层的叶节点数

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> v[100];
int book[100], maxdepth = -1;
void dfs(int index, int depth) {
	//出口 
	if(v[index].size() == 0) {//若当前节点为空 
		book[depth]++; //上一层空节点数++ 
		maxdepth = max(maxdepth, depth);
		return ;
	}
	for(int i = 0; i < v[index].size(); i++)
		dfs(v[index][i], depth + 1);//dfs每个index的孩子节点 
}
int main() {
	int n, m, k, node, c;
	scanf("%d %d", &n, &m);
	for(int i = 0; i < m; i++) {
		scanf("%d %d",&node, &k);//非叶结点编号 以及其孩子个数 
		for(int j = 0; j < k; j++) { //输入每个孩子的编号 
			scanf("%d", &c);
			v[node].push_back(c);//将c拷贝到vector最后一个元素的后面 
		}
	}
	dfs(1, 0);//从第一个节点,第0层开始 
	printf("%d", book[0]);
	for(int i = 1; i <= maxdepth; i++)
		printf(" %d", book[i]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37503890/article/details/87891406
今日推荐