[PAT 甲级]1004 Counting Leaves (30 分) 【dfs 树的遍历】

版权声明:原创博客,转载请标明出处! https://blog.csdn.net/caipengbenren/article/details/88870963

1004 Counting Leaves (30 分)

原题链接
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1


我们用一个领接表记录这个树,用一个visit记录结点i是否出现以及是否有父结点,用dfs遍历这个树,用一个数组统计每一层的叶子结点的个数。最后输出ans数组即可。

这一题的坑点就是如何确定这个树的root,我们用一个visit数组记录:1表示有父节点,0表示出现但是没有父节点,-1表示没有出现过。


 #include<iostream>
#include<vector>
using namespace std;
int n, m;
vector<int >tree[101];
int visit[101]; //1表示有父节点,0表示出现但是没有父节点,-1表示没有出现过。用于找寻root节点
int ans[101];
int maxd = -1;
void dfs(int node, int level) {
    if (tree[node].size() == 0) {
        maxd = max(maxd, level);
        ans[level] += 1;
        return;
    } else {
        int len = int(tree[node].size());
        for (int i = 0; i < len; i++) {
            dfs(tree[node][i], level + 1);
        }
    }
}
int main () {
    cin >> n >> m;
    int a, b, c;
    fill(visit, visit + 101, -1);
    for (int i = 1; i <= m; i++) {
        cin >> a >> b;
        visit[a] = 0;
        for (int j = 1; j <= b; j++) {
            cin >> c;
            tree[a].push_back(c);
            visit[c] = 1;
        }
    }
    int root = 0;
    for (int i = 1; i <= n; i++) {
        if (visit[i] == 0) {
            root = i;
            break;
        }
    }
    dfs(root, 0);
    for (int i = 0; i <= maxd; i++) {
        if (i != 0) {
            cout << " ";
        }
        cout << ans[i];
    }
    return 0;
    
}

猜你喜欢

转载自blog.csdn.net/caipengbenren/article/details/88870963