PAT甲级 1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

题目大意:给出一棵树,问每一层各有多少个叶子结点。

解题思路:利用dfs深度优先遍历,用vector数组保存每一个有孩子结点的结点以及他们的孩子结点,从根结点开始遍历,直到遇到叶子结点,就将当前层数depth的book[depth]++; 注意需保存最大层数,最后打印输出结果。

代码如下:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

vector<int> vec[101];//vector容器数组
int leaf_count[101];
int maxDepth = -1;


void dfs(int index,int depth){
	if(vec[index].size() == 0)
	{
		leaf_count[depth]++;
		maxDepth = max(depth,maxDepth);
		return ;
	}
	for(int i = 0;i < vec[index].size();i++)
		dfs(vec[index][i],depth + 1);
}


int main(){
	int n,m,k;
	cin>>n>>m;
	for(int i=0;i<m;i++){
		int id,id_other;
		cin>>id>>k;
		for(int j=0;j<k;j++){
			cin>>id_other;
			vec[id].push_back(id_other);
		}	
	}
	
	dfs(1,1);
	cout<<leaf_count[1];
	for(int i=2;i<=maxDepth;i++)
		cout<<" "<<leaf_count[i];
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/80944436