1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

AC代码:

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
vector<int>s[105];
int leaf[105];///统计第几层的叶子数。
int mx = 0;
int deep;
void dfs(int deep,int step)
{
    if(s[step].size()==0)
    {
        if(mx<deep)
            mx = deep;///取最大的深度。
        leaf[deep]++;
        return;
    }
    for(int i=0; i<s[step].size(); i++)
    {
        dfs(deep+1,s[step][i]);
    }
}
int main()
{
    int n,m;
    int a,num,b;
    int r[105];
    memset(r,0,sizeof(r));
    cin>>n>>m;
    for(int i=1; i<=m; i++)
    {
        scanf("%d%d",&a,&num);
        for(int j=1; j<=num; j++)
        {
            scanf("%d",&b);
            r[b]++;
            s[a].push_back(b);
        }
    }
    for(int i=1; i<=n; i++)
    {
        if(r[i]==0)
        {
            dfs(0,i);///用dfs求深度,顺便记录每一层的叶子数。
        }
    }
    for(int i=0; i<=mx; i++)
    {
        if(i==mx)
            printf("%d\n",leaf[i]);
        else
            printf("%d ",leaf[i]);
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/ACMerdsb/article/details/84887893
今日推荐