PAT 1095 解码PAT准考证 (25 分)

版权声明:就是码字也不容易啊 https://blog.csdn.net/qq_40946921/article/details/84954101

1095 解码PAT准考证 (25 分)

PAT 准考证号由 4 部分组成:

  • 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
  • 第 2~4 位是考场编号,范围从 101 到 999;
  • 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
  • 最后 11~13 位是考生编号,范围从 000 到 999。

现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

输入格式:

输入首先在一行中给出两个正整数 N(≤10​4​​)和 M(≤100),分别为考生人数和统计要求的个数。

接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。

考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

  • 类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
  • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
  • 类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。

输出格式:

对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

  • 类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
  • 类型 为 2 的指令,按 人数 总分 的格式输出;
  • 类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。

如果查询结果为空,则输出 NA

输入样例:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

输出样例:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

选择好的数据结构可以让代码更直观。

    类型1:根据等级对学生进行分组,也就是一个等级(string)对应一个集合(set),所以用map<string, set<Strint>> rank进行存储,且Strint的排序是按数字非升序,数字count并列按字符串name字典序递增,依此定义Strint结构体的比较方式。

    类型2:按考场进行分组,记录每个考场的总人数和分数,也就是一个考场(string)对应两个int数据组合(pair<int,int>),所以用map<string, pair<int, int>> room;

    类型3:按日期进行分组,每个日期中又按考场分组,记录考场的总人数,也就是一个日期(string)对应一个映射(string-int),所以用map<string, map<string, int>> date,最后输出,由于map无法以key进行排序,所以将map中的元素转到集合(与类型1的集合结构相同)中,再定义集合的排序方式

扫描二维码关注公众号,回复: 4966482 查看本文章

  注意:cin,cout由于存在缓存可能导致时间超时,把cin,cout改成scanf,printf,但scanf不支持string的输入,所以借用tch(char[15])进行输入,再构造string。

Ps:空间耗费太多,类型1和类型3的数据有太多重复

#include<iostream>
#include<string>
#include<set>
#include<map>
using namespace std;
struct Strint {
	string name;
	int count;
	bool operator<(const Strint &other)const {
		if (this->count != other.count)
			return this->count > other.count;
		return this->name < other.name;
	}
};
int main() {
	map<string, set<Strint>> rank;
	map<string, pair<int, int>> room;
	map<string, map<string, int>> date;
	int n, m, tmp;
	char tch[15];
	string str;
	cin >> n >> m;
	for (int i = 0; i < n; i++) {
		scanf("%s %d", &tch, &tmp);
		str = tch;
		Strint student = { str,tmp };
		rank[str.substr(0, 1)].insert(student);
		room[str.substr(1, 3)].first++;
		room[str.substr(1, 3)].second += tmp;
		date[str.substr(4, 6)][str.substr(1, 3)]++;
	}
	for (int i = 1; i <= m; i++) {
		scanf("%d %s", &tmp, &tch);
		str = tch;
		printf("Case %d: %d %s\n", i, tmp, tch);
		if (tmp == 1 && rank[str].size())
			for (auto &it : rank[str])
				printf("%s %d\n", it.name.c_str(), it.count);
		else if (tmp == 2 && room[str].first)
			printf("%d %d\n", room[str].first, room[str].second);
		else if (tmp == 3 && date[str].size()) {
			set<Strint> Room;
			for (auto &it : date[str])
				Room.insert({ it.first,it.second });
			for (auto &it : Room)
				printf("%s %d\n", it.name.c_str(), it.count);
		}
		else printf("NA\n");
	}
	return 0;
}

结构优化 

#include<iostream>
#include<string>
#include<set>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
struct Strint {
	string name;
	int count;
	bool operator<(const Strint &other)const {
		if (this->count != other.count)
			return this->count > other.count;
		return this->name < other.name;
	}
};
int main() {
	map<char, set<Strint>> rank;
	map<string, pair<int, int>> room;
	map<string, vector<Strint>> date;
	int n, m, tmp, key;
	char tch[15];
	string str, roomid, tdate;
	cin >> n >> m;
	for (int i = 0; i < n; i++) {
		scanf("%s %d", &tch, &tmp);
		str = tch;
		string roomid = str.substr(1, 3);
		tdate = str.substr(4, 6);
		rank[str[0]].insert({ str,tmp });
		room[roomid].first++;
		room[roomid].second += tmp;
		vector<Strint>::iterator it = find_if(date[tdate].begin(), date[tdate].end(), [&roomid](Strint &it)->bool {return it.name == roomid; });
		if (it != date[tdate].end())
			it->count++;
		else
			date[tdate].push_back({ roomid,1 });
	}
	for (int i = 1; i <= m; i++) {
		scanf("%d %s", &tmp, &tch);
		str = tch;
		printf("Case %d: %d %s\n", i, tmp, tch);
		if (tmp == 1 && rank[str[0]].size())
			for (auto &it : rank[str[0]])
				printf("%s %d\n", it.name.c_str(), it.count);
		else if (tmp == 2 && room[str].first)
			printf("%d %d\n", room[str].first, room[str].second);
		else if (tmp == 3 && date[str].size()) {
			sort(date[str].begin(), date[str].end());
			for (auto &it : date[str])
				printf("%s %d\n", it.name.c_str(), it.count);
		}
		else printf("NA\n");
	}
	return 0;
}


 

猜你喜欢

转载自blog.csdn.net/qq_40946921/article/details/84954101
今日推荐