PAT (Advanced Level) Practice 1025 PAT Ranking (25 分) (C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/86359856

1025 PAT Ranking (25 分)
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

typedef struct testee
{
    char registration_number[15];//定义成了字符串数组
    int score;
    int final_rank;
    int location_number;
    int local_rank;
}testee;

testee T[30001] = {0};//这里用了一个字符串数组来存储

bool cmp(testee A, testee B)
{
    if(A.score != B.score) return A.score > B.score;
    return strcmp(A.registration_number, B.registration_number) < 0;//字符串按字典序比较
}

int main()
{
    int N = 0, K = 0;
    int i = 0, j = 0, k = 0, cnt = 0;//cnt是输入的下标,或者说输入的个数
    scanf("%d", &N);
    for(i = 1; i<=N; i++)//从1开始
    {
        scanf("%d", &K);
        for(j = 0; j<K; j++, cnt++)
        {
            scanf("%s %d", &T[cnt].registration_number, &T[cnt].score);
            T[cnt].location_number = i;//第几批输入的
        }
        sort(T+cnt-j, T+cnt, cmp);//局部排序
        for(k = cnt-j; k<cnt; k++)
        {
            if(k == cnt-j || k && T[k].score != T[k-1].score)//正常情况
            {
                T[k].local_rank = k - cnt+j + 1;
            }
            else T[k].local_rank = T[k-1].local_rank;//和上一次相同就和上次的顺序相同
        }
    }
    sort(T, T+k, cmp);//总排序
    for(i = 0; i<k; i++)
    {
        if(!i || i && T[i].score != T[i-1].score)
        {
            T[i].final_rank = i+1;
        }
        else T[i].final_rank = T[i-1].final_rank;
    }
    printf("%d\n", cnt);//输出总数
    for(i = 0; i<k; i++)//按要求输出
    {
        printf("%s %d %d %d\n", T[i].registration_number, T[i].final_rank, T[i].location_number, T[i].local_rank);
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86359856