PAT (Advanced Level) Practice A1101 Quick Sort (25 分)(C++)(甲级)(递推)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86571385

1101 Quick Sort (25 分)
There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109 . The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5
Sample Output:

3
1 4 5

//B1045 快速排序 英文版
//https://blog.csdn.net/m0_37454852/article/details/86571342
using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include <ctime>
#include <cmath>

const int MAX_INF = (1<<31) - 1;//无穷大
int A[100010] = {0}, B[100010] = {0};//B存放满足题意的值
int R_min[100010] = {0};//每个元素右侧的最小值

int main()
{
    int N, cnt = 0, left_max = 0;
    scanf("%d", &N);
    for(int i=0; i<N; i++)
    {
        scanf("%d", &A[i]);
    }
    A[N] = MAX_INF, R_min[N] = MAX_INF;
    for(int i=N-1; i>=0; i--)//推算每个元素右侧的最小值,右端点的左侧最小值设置为无穷大
    {
        R_min[i] = min(R_min[i+1], A[i+1]);
    }
    for(int i=0; i<N; i++)
    {
        if(i) left_max = max(left_max, A[i-1]);//该元素左侧最小值
        if(left_max < A[i] && R_min[i] > A[i])//满足左侧最大值小于该数,且右侧最小值大于该数即满足题意
        {
            B[cnt++] = A[i];//存入B中
        }
    }
    printf("%d\n", cnt);
    sort(B, B+cnt);//按递增顺序输出这些元素;然而不排序也能通过貌似
    if(cnt) printf("%d", B[0]);
    else printf("\n");//若无主元必须输出换行符!,否则有一个测试点会出现格式错误;MDZZ辣鸡题目毁我青春
    for(int i=1; i<cnt; i++) printf(" %d", B[i]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86571385