PAT (Advanced Level) Practice A1093 Count PAT's (25 分)(C++)(甲级)(递推思想)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86566314

1093 Count PAT’s (25 分)
The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5 characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT
Sample Output:

2

//本题只需要计算每个A之前P的个数与其之后的T的个数的乘积的累加和即可 //即Pi*Ti(i从1到Anum)的累加和
//在计算Pi和Ti时可以用递推思想,本题表现在程序里即Pi、Ti不清零,继续计算下一个

//B1040 有几个PAT 英文版
//https://blog.csdn.net/m0_37454852/article/details/86566274
using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

int main()
{
    int cnt = 0, Tnum = 0, Px = 0, Tx = 0;
  char S[100010] = {0};//存放字符串
    scanf("%s", S);
    int N = strlen(S);
    for(int i=0; i<N; i++)
    {
        if(S[i] == 'T') Tnum++;//T的总数
    }
    for(int i=0; i<N; i++)
    {
        if(S[i] == 'P') Px++;//某一个A之前P的个数
        if(S[i] == 'T') Tx++;//某一个A之前T的个数;则Tnum - Tx即为该A之后T的个数
        if(S[i] == 'A')
        {
            cnt += Px*(Tnum - Tx);//计算由该A可以组成的PAT的个数;由于S长度小于10^5,故累加不会导致越界
            cnt %= 1000000007;//按题意取余,避免溢出
        }
    }
    printf("%d", cnt);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86566314