HDU 1541 STAR(树状数组)

Stars
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13280    Accepted Submission(s): 5184


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.


Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.


Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.


Sample Input
5
1 1
5 1
7 1
3 3
5 5


Sample Output
1
2
1
1
0

题意:左下角存在的星星个数即为等级,求各个等级的星星数量;
分析:因为输入顺序是从下到上从左到右的,所以只需找该星星输入前左边和该行星所在列星星的个数,
常规方法是用一个a[i]数组记录i列星星总和,然后在每个星星添加前计算0~j列(j为即将添加的星星的列数)的总和,复杂度太高;
正确方法是用一个树状数组c[i]记录星星个数,然后在每个星星添加前计算0~j列(j为即将添加的星星的列数)的总和;
注:lowbit(x)的值就是x到离他最近上一层的距离(lowbit原理

#include<iostream>
#include<algorithm>
#include<string.h>
#define inf 32011
using namespace std;
int c[inf];
int level[inf];
int lowbit(int x){
        return x&-x;
}
void add(int x){
        while(x<inf){
                c[x]++;
                x+=lowbit(x);
        }
}
int sum(int x){
        int sum=0;
        while(x>0){
                sum+=c[x];
                x-=lowbit(x);
        }
        return sum;
}
int main()
{
        int n,x,y;
        while(~scanf("%d",&n)&&n)
        {
                memset(c,0,sizeof(c));
                memset(level,0,sizeof(level));
                for(int i=0;i<n;i++){
                        scanf("%d%d",&x,&y);
                        level[sum(++x)]++;
                        add(x);
                }
                for(int i=0;i<n;i++)
                        printf("%d\n",level[i]);
        }
        return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42060896/article/details/84665039