HDU 1541 star 巧用 树状数组 ʕ •ᴥ•ʔ

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2250    Accepted Submission(s): 858


 

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

 

5 1 1 5 1 7 1 3 3 5 5

Sample Output

 

1 2 1 1 0

这道题的难点在于如何用树状数组来存各个坐标星星的等级。

题意已说明输入的的时候是按Y坐标从小到大排序的,然后可以用一个数组来根据横坐标的大小来记录这个点的星星的的等级。

首先每次读入一个星星的位置后,在它属于的等级的个数+1,然后要更新它之后的横坐标的等级。因为树状数组是从1开始计数的,

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#define N 4000010
#define ll long long 
using namespace std;
int x[32010];
int h[32010];
//树状数组板子 
int lowbit(int w)
{
	return w&-w;
}
int add(int w)
{
	while(w<=32010)
	{
		x[w]++;
		w+=lowbit(w);
	}

}
int sum(int w)
{
	int ans=0;
	while(w>0)
	{
		ans+=x[w];
		w-=lowbit(w);
	}
	return ans;
}
int main()
{
	ios::sync_with_stdio(false);//cin输入的时候需要加速 不然会超时 
	int t;
	cin>>t;
	for(int i=1;i<=t;i++)
	{
		int a,b;
		cin>>a>>b;
		h[sum(a+1)]++;// 记录个数 
		add(a+1);// 添加 
	}
	for(int i=0;i<t;i++)
	cout<<h[i]<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81517810