HDU 1556(树状数组)

Color the ball

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

N个气球排成一排,从左到右依次编号为1,2,3….N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽”牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

Sample Output

1 1 1
3 2 1

问题分析

区间更新的话,线段树会好一些,但是线段树写起来很麻烦…..
依旧是树状数组的板子题,只不过要多想一下,因为这个不是单个节点的值更新,是一个区间,所以我们可以对b以前的区间全部都加一遍,再对a以前的区间减一遍,这样就可以达到a->b区间的更新值。
(关于树状数组的讲解可以参考HDU1166

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int N = 1e5+1;
int n,a,b,bit[N];

inline int lowbit(int x)
{
    return x&(-x);
}

void update(int x,int v)
{
    while(x>0)
    {
        bit[x]+=v;
        x -= lowbit(x);
    }
}

int query(int i)
{
    int sum = 0;
    while(i<=n)
    {
        sum += bit[i];
        i += lowbit(i);
    }
    return sum;
}

int main() {
//    freopen("in.txt","r",stdin);
    while (~scanf("%d",&n),n)
    {
        memset(bit,0, sizeof(bit));
        for(int i = 0; i < n; ++i) {
            scanf("%d%d", &a, &b);
            update(b,1);
            update(a-1,-1);
        }
        for(int i = 0; i < n; ++i)
            printf("%d%c",query(i+1),i==n-1?'\n':' ');
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/eternally831143/article/details/80358513