hdu 1541 Stars(树状数组模板题)

【题目】

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12156    Accepted Submission(s): 4794


 

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

【题解】

题目给的数据按照y排序,相同的y按照x排序,这就给解题带来了很大的方便,我们可以按照由下至上、由左至右的顺序来处理数据,这样我们只利用x就可以进行计数了,因为当我们处理到任意点p的时候,所有的y小于p的点我们已经计数过了,只需要统计所有x不超过p的点的数量就可以了。由于星星的坐标是按y的递增给出的,那么就只需考虑水平方向,如果给出一个星星的坐标为(x,y),那么它的等级就等于前面已经输入的x坐标在[0,x]区间的星星数量。

【代码】

#include<stdio.h>
#include<string.h>
int c[32010],ans[15010];
int n;
int lowbit(int x)
{
    return x&(-x);
}
void update(int x)
{
    while(x<=32000)
    {
        c[x]++;
        x+=lowbit(x);
    }
}
int query(int x)
{
    int res=0;
    while(x)
    {
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}
main()
{
    int x,y;
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        memset(ans,0,sizeof(ans));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            ans[query(x+1)]++;
            update(x+1);
        }
        for(int i=0;i<n;i++)
            printf("%d\n",ans[i]);
    }
}

【...】

这题我真的读了好久...对不起我读书少...

猜你喜欢

转载自blog.csdn.net/qq_41117236/article/details/81181335
今日推荐