HDU1711KMP模板题返回匹配位置

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

 

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

 

Sample Output

 

6 -1

http://acm.hdu.edu.cn/showproblem.php?pid=1711

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[1000001],n,m;
int b[1000001];
int Next[1000005];
void getnext()
{

    /*int j=0,k=-1;
    next[0]=-1;
    while(j<m-1)
    {
        if(k==-1||b[j]==b[k])
        {
            j++;
            k++;
            next[j]=k;

        }
        else{
            k=next[k];
        }
    }
*/
    int j=0,k=-1;
    Next[0]=-1;
    while(j<m-1)
    {
        if(k==-1||b[j]==b[k])
        {
            j++;
            k++;
            Next[j]=k;
        }
        else
            k=Next[k];
    }
}
int KMP()
{

    /*int i=0,j=0;
    while(i<n&&j<m){
        if(j==-1||a[i]==b[i]){
            j++;
            i++;
        }else{
            j=next[j];
        }
    }
    if(j==m){
        return i-j+1;
    }
    return -1;
    */
    int i=0,j=0;
    while(i<n&&j<m)
    {
        if(j==-1||a[i]==b[j])
        {
            i++;
            j++;
        }
        else
            j=Next[j];
    }
    if(j==m)
        return i-j+1;//j是匹配位置;
    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<m; i++)
            scanf("%d",&b[i]);
        getnext();
        int ans=KMP();
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/85028217