PAT (Advanced Level) 1013 Battle Over Cities (25 分)

版权声明:转载请附链接 https://blog.csdn.net/isunLt/article/details/84962169

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

Code

#include <iostream> 
#include <algorithm> 
#include <cstdio> 
using namespace std; 
int v[1001][1001];//记录连通路线 默认为0 不连通 
bool visit[1001];//记录是否遍历过 
int n;//n个城市 
void dfs(int node)
{ 
	visit[node] = true; 
	for(int i=1; i<=n; i++)
	{ 
		if(visit[i]==false && v[node][i] == 1)
		{ 
			dfs(i); 
		} 
	} 
} 
int main() 
{ 
	int m, k, a, b;//m条路 k个要检查的城市 ab为路线起点终点 
	scanf("%d%d%d", &n, &m, &k); 
	for(int i=0; i<m; i++)
	{ 
		scanf("%d%d", &a, &b); 
		v[a][b] = 1; 
		v[b][a] = 1; 
	} 
	for(int i=0; i<k; i++)
	{ 
		fill(visit, visit+1001, false);//重置visit 所有城市未被遍历 
		int temp = 0; 
		scanf("%d", &temp); 
		visit[temp] = true;//被攻占的城市,标记为true 
		int cnt = 0;//记录连通分量 
		for(int j=1; j<=n; j++)
		{ 
			if(visit[j] == false)
			{ 
				dfs(j); 
				cnt++;//连通分量+1 
			} 
		}
		printf("%d\n", cnt-1);//思路第二条 
	} 
	return 0; 
}

思路

以上代码来自 https://blog.csdn.net/cv_jason/article/details/81019874 本来照着他的代码自己打了一遍,但是在最后超时了,原因是我用了cin和cout,而他用的是scanf和printf,发现这个原因不是很震惊,因为之前也听ACM大佬说cin和cout比scanf和printf慢很多,但是,因为懒,所以一直用cin和cout。。。

以上

猜你喜欢

转载自blog.csdn.net/isunLt/article/details/84962169
今日推荐