1013 Battle Over Cities (25)(25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city~1~-city~2~ and city~1~-city~3~. Then if city~1~ is occupied by the enemy, we must have 1 highway repaired, that is the highway city~2~-city~3~.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (&lt1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

添加最少的路线,就是它的连通分量数减少1 

 使用邻接矩阵存储,对于每一个被占领的城市,去除这个城市结点,就是把它标记为已经访问过,这样在bfs优先遍历或者dfs

遍历的时候,对于所有未访问的结点进行遍历,就能求到所有的连通分量的个数 ,记得因为有很多个要判断的数据,每一次输入被占领的城市之前要把visit数组置为false~~~~

做题要灵活

dfs

#include<bits/stdc++.h>
using namespace std;
int n,m,q;
int vis[1005];
int mapp[1005][1005];

void dfs(int x)
{
    for(int i=1;i<=n;i++){
        if(!vis[i]&&(mapp[x][i]==1)){
            vis[i]=1;
            dfs(i);

        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    memset(mapp,0,sizeof(mapp));
    cin>>n>>m>>q;
    for(int i=0;i<m;i++){
        int a,b;
        cin>>a>>b;
        mapp[a][b]=mapp[b][a]=1;
    }
    for(int i=0;i<q;i++){
        memset(vis,0,sizeof(vis));
        int cnt=0;
        int x;
        cin>>x;
        vis[x]=true;
        for(int j=1;j<=n;j++){
            if(!vis[j]){
                vis[j]=1;
                cnt++;
                dfs(j);
            }
        }
        cout<<cnt-1<<endl;
    }
    return 0;
}

bfs

#include<bits/stdc++.h>
using namespace std;
int n,m,q;
int vis[1005];
int mapp[1005][1005];

void bfs(int x)
{
    queue<int>Q;
    Q.push(x);
    while(!Q.empty()){
        int u=Q.front();
        Q.pop();
        for(int i=1;i<=n;i++){
            if(!vis[i]&&(mapp[u][i])){
                vis[i]=1;
                Q.push(i);
            }
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    memset(mapp,0,sizeof(mapp));
    cin>>n>>m>>q;
    for(int i=0;i<m;i++){
        int a,b;
        cin>>a>>b;
        mapp[a][b]=mapp[b][a]=1;
    }
    for(int i=0;i<q;i++){
        memset(vis,0,sizeof(vis));
        int cnt=0;
        int x;
        cin>>x;
        vis[x]=true;
        for(int j=1;j<=n;j++){
            if(!vis[j]){
                vis[j]=1;
                cnt++;
                bfs(j);
            }
        }
        cout<<cnt-1<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Wchenchen0/article/details/81432054