PAT (Advanced Level) 1013. Battle Over Cities (25) DFS求连通分量

题目链接

1013. Battle Over Cities (25)

Time limit:400 ms Memory limit:65536 kB


Problem Descrpition

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

题意

给一个无向图,问去掉某点后,至少需要几条边连接才能构成连通图

解题思路

去掉点之后求连通分量,如果有n个连通分量,那么最少用n-1条边连接就可以构成连通图

Code

#include "cstdio"
#include "iostream"
#include "cstring"
using namespace std;

const int maxn=1005,maxm=maxn*maxn;
struct Edge
{
    int to,next;
};
Edge e[maxm];
int head[maxn];
bool vis[maxn];
int flag[maxn];
int N,M;
int edge;
int ruined;

void init()
{
    edge=0;
    memset(head,-1,sizeof(head));
}

void addEdge(int u,int v)
{
    e[edge].to=v,e[edge].next=head[u],head[u]=edge++;
}

void DFS(int k)
{
    vis[k]=true;
    for(int i=head[k];i!=-1;i=e[i].next)
    {
        int u=e[i].to;
        if(u!=ruined&&(!vis[u]))
        {
            vis[u]=true;
            DFS(u);
        }
    }
}

int main()
{
    init();
    int n,m,k;
    cin>>n>>m>>k;
    for(int i=0;i<m;i++)
    {
        int u,v;
        cin>>u>>v;
        addEdge(u,v);
        addEdge(v,u);
    }
    while(k--)
    {
        cin>>ruined;
        memset(vis,false,sizeof(vis));
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            if(i==ruined)
                continue;
            if(!vis[i])
            {
                DFS(i);
                cnt++;
            }
        }
        cout<<cnt-1<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xp731574722/article/details/80084136
今日推荐