1013 Battle Over Cities (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Whomio/article/details/86572632

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

Solution Code:

  • 使用cin输入存在超时问题,因为对于大量输入操作,cin有同步机制,所以推荐使用scanf(或者禁用cin同步)。
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

/*************************
用邻接矩阵存储城市和道路之间的关系。

该问题可转化为:
删除连通图中的一个节点后,需要多少条边,使得其他节点再次成为连通图。
需要最少边数 = 连通分量 - 1。

由于修改矩阵过于繁琐,可以设被攻占的城市被访问过。
**************************/

// 矩阵表示城市间道路
int roads[1001][1001] = {0}; //无穷大
int visited_citys[1001] = {0}; //未被访问过

void dfs(int size, int begin_city)
{
	visited_citys[begin_city] = 1;
	for (int i = 1; i <= size; ++i) {
		if (roads[begin_city][i] == 1 && visited_citys[i] == 0) {
			dfs(size, i);
			break;
		}
	}
}

int getRepaired(int size, int city)
{
	int connected_component = 0; //连通分量

	memset(visited_citys, 0, sizeof(visited_citys));
	visited_citys[city] = 1;

	// 寻找连通分量
	for (int i = 1; i <= size; ++i) {
		if (visited_citys[i] == 0){
			dfs(size, i);
			connected_component++;
		} 
	}

	return connected_component - 1;
}

int main()
{
	// n - the total number of cities
	// m - the number of remaining highways
	// k - the number of cities to be checked
	// ios::sync_with_stdio(false); //禁用cin同步
	int n, m, k;
	scanf("%d %d %d", &n, &m, &k);

	for (int i = 0; i < m; ++i){
		int begin, end;
		scanf("%d %d", & begin, &end);
		roads[begin][end] = 1;
		roads[end][begin] = 1;
	}

	int city, repaired_roads;
	for (int i = 0; i < k; ++i){
		scanf("%d", &city);
		repaired_roads = getRepaired(n, city);
		cout << repaired_roads << endl;
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/Whomio/article/details/86572632