1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​​-city2​​ and city1​​-city3​​. Then if city1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​​-city3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int v[1001][1001];//记录连通路线 默认为0 不连通
bool visit[1001];//记录是否遍历过
int n;//n个城市


void dfs(int node){//递归来对图进行遍历************************
    visit[node] = true;
    for(int i=1; i<=n; i++){
        if(visit[i]==false && v[node][i] == 1){
            dfs(i);
        }
    }
}
int main()
{
    int m, k, a, b;//m条路 k个要检查的城市 ab为路线起点终点
    cin>>n>>m>>k;
    for(int i=0; i<m; i++){//将二维数组赋值,1代表有路
        cin>>a>>b;
        v[a][b] = 1;
        v[b][a] = 1;
    }
    for(int i=0; i<k; i++){
        fill(visit, visit+1001, false);//重置visit 所有城市未被遍历
        int temp = 0;
        cin>>temp;
        visit[temp] = true;//被攻占的城市,标记为true
        int cnt = 0;//记录连通分量
        for(int j=1; j<=n; j++){
            if(visit[j] == false){
                dfs(j);
                cnt++;//连通分量+1
            }
        }
        cout<<cnt-1<<endl;//cnt个连通分量之间应有n-1条路
    }
    return 0;
}



猜你喜欢

转载自www.cnblogs.com/TBhacker/p/11299450.html