数据结构实验之二叉树的建立与遍历(先序->中序+后序+叶子+深度)

Problem Description

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

 

Input

 输入一个长度小于50个字符的字符串。

Output

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

Sample Input

abc,,de,g,,f,,,

Sample Output

cbegdfa
cgefdba
3
5

Hint

 

扫描二维码关注公众号,回复: 5373681 查看本文章

Source

ma6174

#include<bits/stdc++.h>
using namespace std;
struct node
{
    node *l,*r;
    char data;
};
char a[100];
int top,sum;
node *create()
{
    node *root;
    root=new node;
    top++;
    if(a[top]==',')
        return NULL;
    else
    {
        root=new node;
        root->data=a[top];
        root->l=create();
        root->r=create();
    }
    return root;
}
int getleafsum(node *root)
{
    if(root)
    {
        if(root->l==NULL&&root->r==NULL)
            sum++;
        else
        {
            getleafsum(root->l);
            getleafsum(root->r);
        }
    }
    return sum;
}
int getdepth(node *root)
{
    int depth=0;
    if(root)
        depth=max(getdepth(root->l),getdepth(root->r))+1;
    return depth;
}

void middleshow(node *root)
{
    if(root)
    {
        middleshow(root->l);
        cout<<root->data;
        middleshow(root->r);
    }
}
void finallshow(node *root)
{
    if(root)
    {
        finallshow(root->l);
        finallshow(root->r);
        cout<<root->data;
    }
}
int main()
{
    cin>>a;
    top=-1;
    node *root;
    root=create();
    middleshow(root);
    cout<<endl;
    finallshow(root);
    cout<<endl;
    cout<<getleafsum(root)<<endl;
    cout<<getdepth(root)<<endl;
    return 0;
}


/***************************************************
User name: ACM18171信科1801张林
Result: Accepted
Take time: 0ms
Take Memory: 216KB
Submit time: 2019-02-25 13:35:48
****************************************************/

猜你喜欢

转载自blog.csdn.net/weixin_43824158/article/details/87915437