hdoj 1087 Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51926 Accepted Submission(s): 24066

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3

先来一段蜜汁翻译:
超级跳跳跳
一行有n个位置,可以从任意一个开始跳。只能跳向比当前数值大的位置,并且把落点的值加起来,最后输出最大的和。
清奇的思路
每个位置记录,这个位置的数值num,以及跳到这个位置时的最大和max。
每个位置i都向前寻找一个最大的位置j作为上一个落点,j要满足两个条件:1、位置j的数值num比当前位置i的数值小num。2、在满足上一个条件的情况下,位置j的最大和max应该也是最大的。然后i.max=j.max+i.num.最后只需要把这些位置中的最大的max输出就行了

#include<stdio.h>
struct p{
    int num;
    int max;
};
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        struct p a[1001];
        int i;
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i].num);
            int j;
            int ans=0;
            for(j=0;j<i;j++)
            {
                if(a[j].num<a[i].num&&ans<a[j].max)
                    ans=a[j].max;
            }
            a[i].max=a[i].num+ans;
        }
        int ans=0;
        for(i=0;i<n;i++)
        {
            if(a[i].max>ans)
                ans=a[i].max;
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/D_mengxin/article/details/84729025