hdu 4280 Island Transport 网络流 模板 ʕ •ᴥ•ʔ

hdu 4280 Island Transport

Description
  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.

Input
  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.

Output
  For each test case, output an integer in one line, the transport capacity.

Sample Input

2
5 7
3 3
3 0
3 1
0 0
4 5
1 3 3
2 3 4
2 4 3
1 5 6
4 5 3
1 4 4
3 4 2
6 7
-1 -1
0 1
0 2
1 0
1 1
2 3
1 2 1
2 3 6
4 5 5
5 6 3
1 4 6
2 5 5
3 6 4

Sample Output

9
6

题目大意:有n个岛, m条路。每条路,都有一个容量,代表一小时内能运送的游客量。现在求从最西边的岛到最东边的岛在一小时内最多能运送多少的游客。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<queue>
#define N 0x3f3f3f3f
#define ll long long
using namespace std;
int n,m;
int s,e;//
int cnt;
int per[100010];
int cur[100010];
struct ac
{
	int nxt,v,w;
}r[800010];
void add(int u,int v,int w)
{
	r[cnt].v=v;
	r[cnt].w=w;
	r[cnt].nxt=per[u];
	per[u]=cnt++;
} 
int dis[100010];
int bfs()
{
	//memset(dis,-1,sizeof(dis)); 
	for(int i=1;i<=n;i++)
	dis[i]=-1;
	queue<int>q;
	q.push(s);
	dis[s]=0;
	while(!q.empty())
	{
	int u=q.front();
	q.pop();
	for(int i=per[u];i!=-1;i=r[i].nxt)
	{
		if(dis[r[i].v]==-1&&r[i].w>0)
		{
			dis[r[i].v]=dis[u]+1;
			q.push(r[i].v);
		}
	}
	
	}
	if(dis[e]>-1)
	return 1;
	return 0;
}
int dfs(int u,int h)
{
	if(u==e||h==0)
	return h;
	int flow,f=0;
	for(int &i=cur[u];i!=-1;i=r[i].nxt)// & 取地址符  
	{
		if(dis[r[i].v]==dis[u]+1&&r[i].w>0&&(flow=dfs(r[i].v,min(h,r[i].w)))>0)
		{
			r[i].w-=flow;
			r[i^1].w+=flow;
			h-=flow;
			f+=flow;
			if(h==0)
			break;
		}
	}
	return f;
}
int main()
{
	ios::sync_with_stdio(false);
	int t;
	cin>>t;
	while(t--)
	{
		
		cin>>n>>m;
		memset(r,0,sizeof(r));
		int imax=-N,imin=N;
		for(int i=1;i<=n;i++)
		{
			int a,b;
			cin>>a>>b;//寻找起点 和 终点 
			if(a>imax)
			{
				e=i; 
				imax=a;
			} 
			if(a<imin)
			{
				s=i;
				imin=a;
			}
		}
		cnt=0;
		
		
		
		
		memset(per,-1,sizeof(per));
		for(int i=1;i<=m;i++)
		{
			int u,v,w;
			cin>>u>>v>>w;
			add(u,v,w);// 数组模拟链表 
			add(v,u,w);
		}
		int ans=0;
		while(bfs())
		{
			for(int i=0;i<=n;i++)
			{
				cur[i]=per[i];//弧优化 
			}
			ans+=dfs(s,N);
		}
		cout<<ans<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81914639
今日推荐