hdu 魔咒词典

           魔咒词典

Time Limit : 8000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 51   Accepted Submission(s) : 23

Problem Description

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input

首先列出词典中不超过100000条不同的魔咒词条,每条格式为: [魔咒] 对应功能 其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。 词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input

[expelliarmus] the disarming charm

[rictusempra] send a jet of silver light to hit the enemy

[tarantallegra] control the movement of one's legs

[serpensortia] shoot a snake out of the end of one's wand

[lumos] light the wand

[obliviate] the memory charm

[expecto patronum] send a Patronus to the dementors

[accio] the summoning charm

@END@

4

[lumos]

the summoning charm

[arha]

take me to the sky

Sample Output

light the wand

accio

what?

what?

题意:给出一个串,比如[expelliarmus] the disarming charm,前面[expelliarmus]又是一个串,后面的the disarming charm算一个,查询前或后任意一个,都能找到他的后或者前。

用俩个数组来存储前后串,空格用gets()接收,for循环遍历

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string a;
    string s1[100005];
    string s2[100005];
    int n=0;
    while(cin>>a)
    {
        char m[1000];
        string s;
        if(a=="@END@") break;
        gets(m);
        int L=strlen(m);
        for(int i=1; i<L; i++)
        {
            s=s+m[i];
        }
        s1[n]=a;
        s2[n]=s;
        n++;
    }
    int t;
    scanf("%d\n",&t);
    while(t--)
    {
        char m[1000];
        string s;
        gets(m);
        int L=strlen(m);
        for(int i=0; i<L; i++)
        {
            s=s+m[i];
        }
        if(m[0]=='[')
        {
            int p=-1;
            for(int i=0; i<n; i++)
            {
                if(s1[i]==s)
                {
                    p=i;
                    break;
                }
            }
            if(p!=-1)
                cout<<s2[p]<<endl;
            else
                printf("what?\n");
        }
        else
        {
            int p=-1;
            for(int i=0; i<n; i++)
            {
                if(s2[i]==s)
                {
                    p=i;
                    break;
                }
            }
            if(p!=-1)
            {
               for(int i=1; i<s1[p].length()-1; i++)
                    printf("%c",s1[p][i]);
                printf("\n");
            }
            else
            {
                printf("what?\n");
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/smilelingling/article/details/83651952
hdu