HDU 1880 魔咒词典

魔咒词典

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16378    Accepted Submission(s): 3860


 

Problem Description

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

 

Input

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

 

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

 

Sample Input

 

[expelliarmus] the disarming charm

[rictusempra] send a jet of silver light to hit the enemy

[tarantallegra] control the movement of one's legs

[serpensortia] shoot a snake out of the end of one's wand

[lumos] light the wand

[obliviate] the memory charm

[expecto patronum] send a Patronus to the dementors

[accio] the summoning charm

@END@

4

[lumos]

the summoning charm

[arha]

take me to the sky

 

Sample Output

 

light the wand

accio

what?

what?

 

Author

ZJU

 

Source

浙大计算机研究生复试上机考试-2008年

 

Recommend

We have carefully selected several similar problems for you:  1881 1075 1800 1251 2222 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char name[100000][30];
char tool[100000][90];
char input[120];
char stemp[120];
int index = 0;
int main()
{
	int n;
	while (gets(input)) {
		if (strcmp(input, "@END@") == 0)
			break;	
		int len = strlen(input);
		int i = 0;
		while (i < len) {
			name[index][i] = input[i++];
			if (input[i - 1] == ']') {
				name[index][i] = '\0';
				break;
			}
		}
		int j = 0;
		i = i + 1;
		while (i < len) {
			tool[index][j++] = input[i++];
		}
		tool[index++][j] = '\0';
	}
	
	while (scanf("%d", &n) != EOF) {
		getchar();
		for (int i = 0; i < n; i++) {
			gets(stemp);
			int flag = 0;
			if (stemp[0] == '[') {
				for (int j = 0; j < index; j++) {
					if (strcmp(name[j], stemp) == 0) {
						printf("%s\n", tool[j]);
						flag = 1;
						break;
					}
				}
			}
			else {
				for (int j = 0; j < index; j++) {
					if (strcmp(tool[j], stemp) == 0) {
						int len = strlen(name[j]);
						for (int k = 1; k < len - 1; k++)
							printf("%c", name[j][k]);
						printf("\n");
						flag = 1;
						break;
					}
				}
			}
			if (flag == 0)
				printf("what?\n");
		}
	}
	return 0;
}

这题是一题基础的字符串题目,其中有两个要注意的地方,一个是输入的时候,gets以及scanf()都很难直接把魔法名字和用途直接分开(当然也可能会有笔者不知道的方法),所以在输入的时候要进行一个分割,第二个要注意的地方就是那个输出的时候是不可以带[ ]这个符号的,因此直接用for去进行输出忽略掉这个括号就好了。

猜你喜欢

转载自blog.csdn.net/curry3030/article/details/81211824
今日推荐