HDU1880 魔咒词典【字符串hash+映射】

魔咒词典

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16888    Accepted Submission(s): 3995


 

Problem Description

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output

light the wand
accio
what?
what?

 Author

ZJU

Source

浙大计算机研究生复试上机考试-2008年

题目链接:HDU1880 魔咒词典

题解:如果数据量小,每个字符串的长度小的话,直接使用map<string,string>轻松解决,但是数据量大,字符串的长度可能很长,这样会造成超时和超内存的问题,因此使用字符串hash和映射解决

AC的C++代码如下

#include<iostream>
#include<string> 
#include<map>
#include<utility>

using namespace std;
typedef unsigned long long ull;
const int N=200010;
const ull p=1e9+13;
const ull mod=1e9+7;
string a[N]; 
map<ull,int>d;

ull hashstr(string s)  //hash函数
{
	ull v=0;
	for(int i=0;s[i];i++)
	  v=(v*p+(int)s[i])%mod;
	return v;
}

int main()
{
	int k=0,n;
	for(;;){
		string s1,s2,s;
		getline(cin,s);
		int p1=s.find("[",0);
		int p2=s.find("] ",p1+1);
		if(p1==string::npos||p2==string::npos)
		  break;
		s1=s.substr(p1+1,p2-p1-1);//s1为名字
		s2=s.substr(p2+2);//s2为功能
		a[++k]=s1;
		ull v=hashstr(s2);
		d.insert(make_pair(v,k));
		a[++k]=s2;
		v=hashstr(s1);
		d.insert(make_pair(v,k));
	}
	scanf("%d",&n);
	getchar();
	for(int i=1;i<=n;i++){
		string s;
		getline(cin,s);
		if(s[0]=='['){
			s.erase(s.end()-1);
			s.erase(s.begin());
		}
		ull v=hashstr(s);
		if(d.find(v)!=d.end()){
			int pos=(d.find(v))->second;;
			cout<<a[pos]<<endl;
		}
		else
		  cout<<"what?"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/82777746