魔咒词典 HDU1880 字符串哈希

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
Sample Input
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
Sample Output
light the wand
accio
what?
what?

分析
一道字符串哈希的题目,重点在于如何哈希字符串,这是第一道哈希的题目,在网上学习了一些哈希的算法。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;
const int maxn = 100000 + 10;
const int mod = 100000 + 7;
char s1[maxn][30];
char s2[maxn][90];
int cnt1,cnt2;
struct node
{
    unsigned int hash_;
    int val;
    bool operator<(const node &rhs)const
    {
        return hash_<rhs.hash_;
    }
}a[maxn],b[maxn];
//unsigned int gethash(char *s)
//{
//    unsigned int hash=0;
//    for(int i=0;i<strlen(s);i++)
//    {
//        hash^=(hash^5)+(int)s[i]+(hash>>2);
//    }
//    return hash & 0x7FFFFFFF ;
//}
unsigned int gethash(char *s)
{
    unsigned int seed=131;
    unsigned int hash=0;
    for(int i=0;i<strlen(s);i++)
    {
        hash=hash*seed+(int)s[i];
    }
    return hash &0x7FFFFFFF ;
}
void solve()
{
    for(int i=0;i<cnt1;i++)
    {
        a[i].hash_=gethash(s1[i]);
        a[i].val=i;
        b[i].hash_=gethash(s2[i]);
        b[i].val=i;
    }
}
int main()
{
    char s[200];
    while(scanf("%s",s1[cnt1++]))
    {
        if(strcmp(s1[cnt1-1],"@END@")==0) break;
        getchar();
        gets(s2[cnt2++]);
    }
    cnt1--;
    solve();
    sort(a,a+cnt1);
    sort(b,b+cnt2);
    int n;
    scanf("%d",&n);
    getchar();
    for(int i=0;i<n;i++)
    {
        gets(s);
        //cout<<s<<endl;
        unsigned int h=gethash(s);
       // cout<<h<<endl;
        if(s[0]=='[')
        {
            int pos=-1;
            for(int j=0;j<cnt2;j++)
            {
                if(a[j].hash_==h){pos=j; break;}
            }
            if(pos==-1)
            {
                printf("what?\n");
            }
            else
            {
                printf("%s\n",s2[a[pos].val]);
            }
        }
        else
        {
            int pos=-1;
            for(int j=0;j<cnt2;j++)
            {
                if(b[j].hash_==h){pos=j; break;}
            }
            if(pos==-1)
            {
                printf("what?\n");
            }
            else
            {
                int now=b[pos].val;
                for(int j=1;j<strlen(s1[now])-1;j++)
                    printf("%c",s1[now][j]);
                printf("\n");
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/CURRYWANG97/article/details/81836853
今日推荐