HDU 1880 魔咒词典 (Hash)

魔咒词典

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16641    Accepted Submission(s): 3916


Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
 
Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
 
Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
 
Sample Input
[expelliarmus] the disarming charm [rictusempra] send a jet of silver light to hit the enemy [tarantallegra] control the movement of one's legs [serpensortia] shoot a snake out of the end of one's wand [lumos] light the wand [obliviate] the memory charm [expecto patronum] send a Patronus to the dementors [accio] the summoning charm @END@ 4 [lumos] the summoning charm [arha] take me to the sky
 
Sample Output
light the wand accio what? what?
 
思路:
我的第二道hash题,第一道是使用map来存hash值,但是这题用map就会爆内存,所以要使用结构体来存,找的时候二分。
map只是写起来方便罢了,它的复杂度是nlogn,而二分同样是nlogn,不知道为什么用map会爆内存,但是以后用map要小心了。
代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
using namespace std;
typedef unsigned long long ll;
long long seed = 9731;
char s[40];
struct Hash
{
    ll num;
    string s;

    bool operator<(const Hash x)const
    {
        return x.num<num;
    }

}a[100086],b[100086],exa;
int main()
{
    string pos,pre;
    char c;
    int nn=0;
    while(true){
        scanf("%c",&c);
        if(c=='@'){break;}
        if(c!='['){continue;}
        ll ss=seed,num=0;
        pre.clear();
        while(true){
            scanf("%c",&c);
            if(c==']'){break;}
            num+=c*ss;pre.push_back(c);
            ss*=ss;
        }
        getchar();
        getline(cin,pos);
        a[nn].num=num;
        a[nn].s=pos;
        int l=pos.length();
        ss=seed,num=0;
        for(int i=0;i<l;i++){
            num+=pos[i]*ss;
            ss*=ss;
        }
        b[nn].num=num;
        b[nn].s=pre;
        nn++;
    }
    scanf("%s",s);
    int q;
    scanf("%d",&q);
    sort(a,a+nn);
    sort(b,b+nn);
    getchar();
    while(q--){
        getline(cin,pos);
        ll num=0,ss=seed;
        int l=pos.length();
        if(pos[0]=='['){
            for(int i=1;i<l-1;i++){
                num+=ss*pos[i];
                ss*=ss;
            }
            int y;
            exa.num=num;//cout<<num<<endl;
            y=lower_bound(a,a+nn,exa)-a;
            if(a[y].num!=num){cout<<"what?"<<endl;}
            else cout<<a[y].s<<endl;
        }
        else{
            for(int i=0;i<l;i++){
                num+=ss*pos[i];
                ss*=ss;
            }
            int y;

            exa.num=num;
            y=lower_bound(b,b+nn,exa)-b;
            if(b[y].num!=num){cout<<"what?"<<endl;}
            else cout<<b[y].s<<endl;
        }
    }
}

  

 

猜你喜欢

转载自www.cnblogs.com/ZGQblogs/p/9448618.html