Kindergarten (二分匹配)

     In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
Input
    The input consists of multiple test cases. Each test case starts with a line containing three integers
    G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
    the number of pairs of girl and boy who know each other, respectively.
    Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
    The girls are numbered from 1 to G and the boys are numbered from 1 to B.

    The last test case is followed by a line containing three zeros.
Output
    For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
Sample Input

    2 3 3
    1 1
    1 2
    2 3
    2 3 5
    1 1
    1 2
    2 1
    2 2
    2 3
    0 0 0

Sample Output

    Case 1: 3
    Case 2: 4

题意:有一群孩子,男孩之间互相认识,女孩之间互相认识,另外有部分男孩和女孩也是认识的。现在老师需要选出一个孩子集合,集合中所有的孩子都互相认识。求集合的最大元素个数。

分析:这道题是一个匹配题,那么我们就要想办法把各种情况转化为最大匹配来算。

       首先我们可以通过题目的输入构建一张图,用邻接矩阵表示,这张图就是关系图,如果两个人认识,就记为1。不认识就记为0。然后我们可以把图转化为补图,那么补图中有边就表示这两个人其实是不认识的,那么我们要做的就是求最小顶点覆盖(找最少的顶点覆盖所有的边),把这些顶点去除后补图中就没有边了,那么就表示在原图中这些人是互相认识的。即求出答案。

【再来看这题,题目中,男生是一个点集,男生都互相认识,女生是一个点集,女生都互相认识,则这个图的补图肯定是二分图。因为补图的边一个端点在男生点集,一个端点在女生点集。确认是二分图后,求二分图的最大独立集】

#include<stdio.h>
#include<string.h>
int m,n,g,e[410][410],match[410],book[410];
int dfs(int u)
{
	int i;
	for(i = 1; i <= g; i ++)
	{
		if(book[i] == 0 && e[u][i] == 1)
		{
			book[i] = 1;
			if(match[i] == 0 || dfs(match[i]))
			{
				match[i] = u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,k,x,y,sum,count=1;
	while(scanf("%d%d%d",&n,&m,&k), n!=0||m!=0||k!=0)
	{
		sum = 0;
		g = n + m;
		memset(e,0,sizeof(e));
		memset(match,0,sizeof(match));
		for(i = 1; i <= m; i ++)
			for(j = 1; j <= m; j ++)
				e[i][j] = 1;
		for(i = m+1; i <= g; i ++)
			for(j = m+1; j <= g; j ++)
				e[i][j] = 1;
		for(i = 0; i < k; i ++)
		{
			scanf("%d%d",&x,&y);
			e[x+m][y] = 1;
			e[y][x+m] = 1;
		}
		for(i = 1; i <= g; i ++)
			for(j = 1; j <= g; j ++)
				if(e[i][j] == 1)
					e[i][j] = 0;
				else
					e[i][j] = 1;
		for(i = 1; i <= g; i ++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum ++;
		}
		printf("Case %d: %d\n",count ++,g-(sum/2));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81538617