hdu 1083( 最大二分匹配)

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9485    Accepted Submission(s): 4600


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
 
  
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
 
  
YES NO
 
题意:给出若干课程,给出学习这门课的若干学生,寻找是否可以满足每门课都可以匹配到一个学生,显然可以用二分匹配
#include <stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[1001][1001];
int visit[1001];
int student[1001];	
int p,n;//课程 学生
int find(int x)
{
	int i;
	for(i=1;i<=n;i++)	
	{
		if(map[x][i]==1&&visit[i]==0)
		{
			visit[i]=1;
			if(student[i]==0||find(student[i]))
			{
				student[i]=x;
				return  1;
			}	
		}
	}
	return 0;
}
int main(int argc, char *argv[])
{
	int t;
	scanf("%d",&t);
	while(t--)
	{	 
		scanf("%d %d",&p,&n);
		memset(map,0,sizeof(map)); 
		memset(student,0,sizeof(student));
		int i,j;
		for(j=1;j<=p;j++)
		{	
			int n1,a;
			scanf("%d",&n1);
			for(i=0;i<n1;i++)
			{
				scanf("%d",&a);
				map[j][a]=1;
			}
		}
		int sum=0;
		for(i=1;i<=p;i++)
		{
			memset(visit,0,sizeof(visit));
			if(find(i))
			{
				sum++;
			}
		}
		if(sum==p)
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/com_ice/article/details/79620461