Sorting Slides【二分匹配】

Sorting Slides

Professor Clumsey is going to give an important talk this afternoon. Unfortunately, he is not a very tidy person and has put all his transparencies on one big heap. Before giving the talk, he has to sort the slides. Being a kind of minimalist, he wants to do this with the minimum amount of work possible.
The situation is like this. The slides all have numbers written on them according to their order in the talk. Since the slides lie on each other and are transparent, one cannot see on which slide each number is written.

Well, one cannot see on which slide a number is written, but one may deduce which numbers are written on which slides. If we label the slides which characters A, B, C, … as in the figure above, it is obvious that D has number 3, B has number 1, C number 2 and A number 4.

Your task, should you choose to accept it, is to write a program that automates this process.

Input

The input consists of several heap descriptions. Each heap descriptions starts with a line containing a single integer n, the number of slides in the heap. The following n lines contain four integers xmin, xmax, ymin and ymax, each, the bounding coordinates of the slides. The slides will be labeled as A, B, C, … in the order of the input.

This is followed by n lines containing two integers each, the x- and y-coordinates of the n numbers printed on the slides. The first coordinate pair will be for number 1, the next pair for 2, etc. No number will lie on a slide boundary.

The input is terminated by a heap description starting with n = 0, which should not be processed.

Output

For each heap description in the input first output its number. Then print a series of all the slides whose numbers can be uniquely determined from the input. Order the pairs by their letter identifier.

If no matchings can be determined from the input, just print the word none on a line by itself.

Output a blank line after each test case.

Sample Input

4
6 22 10 20
4 18 6 16
8 20 2 18
10 24 4 8
9 15
19 17
11 7
21 11
2
0 2 0 2
0 2 0 2
1 1
1 1
0

Sample Output

Heap 1
(A,4) (B,1) (C,2) (D,3)
  
Heap 2
none

题意概括:

  有n张透明的纸摞在一起,给出每张纸的坐标和标号的坐标,求出能够唯一确定的标号的 纸及其标号。

解题分析:

  这道题其实是一个二分匹配问题,看有哪些标号与纸张是必要的匹配关系,若是则输出。

AC代码:

#include<stdio.h>
#include<string.h>

#define N 1005

struct node{
    int x1, x2, y1, y2;
}s[N];
struct nod{
    int x, y;
}h[N];

int n;
int book[N], match[N], e[N][N];

bool Find(int u)
{
    for(int i = 1; i <= n; i++){
        if(e[u][i] && !book[i]){
            book[i] = 1;
            if(!match[i] || Find(match[i])){
                match[i] = u;
                return true;
            }
        }
    }
    return false;
}

bool Judge(nod a, node b)
{
    if(a.x >= b.x1 && a.x <= b.x2 && a.y >= b.y1 && a.y <= b.y2)
        return true;
    return false;
}

int f(void)
{
    int i;
    memset(match, 0, sizeof(match));
    for(i = 1; i <= n; i++){
        memset(book, 0, sizeof(book));
        if(!Find(i)) return 0;
    }
    return 1;
}

int main()
{
    int i, j, k, x, y, ans, flag, t = 1;
    while(scanf("%d", &n), n){
        memset(e, 0, sizeof(e));
        flag = 0;
        for(i = 1; i <= n; i++) scanf("%d%d%d%d", &s[i].x1, &s[i].x2, &s[i].y1, &s[i].y2);
        for(i = 1; i <= n; i++) scanf("%d%d", &h[i].x, &h[i].y);
        for(i = 1; i <= n; i++){
            for(j = 1; j <= n; j++)
                if(Judge(h[j], s[i])) e[i][j] = 1;
        }
        printf("Heap %d\n", t++);
        for(i = 1; i <= n; i++){
            for(j = 1; j <= n; j++){
                if(!e[i][j]) continue;
                e[i][j] = 0;
                if(!f()){
                    if(!flag){
                        printf("(%c,%d)", 'A'+i-1, j);
                        flag = 1;
                    }
                    else printf(" (%c,%d)", 'A'+i-1, j);
                    for(k=1;k<=n;k++){
                        if(k!=i) e[k][j] = 0;
                        if(k!=j) e[i][k] = 0;
                    }
                }
                e[i][j] = 1;
            }
        }
        if(!flag) printf("none");
        printf("\n\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/k_young1997/article/details/79274430