1040 有几个PAT(25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/piaoliangjinjin/article/details/81781407

字符串APPAPT中包含了两个单词“PAT”,其中第一个PAT是第2位(P),第4位(A),第6位(T);第二个PAT是第3位(P),第4位(A),第6位(T)。

现给定字符串,问一共可以形成多少个PAT?

输入格式:

输入只有一行,包含一个字符串,长度不超过10^5^,只包含P、A、T三种字母。

输出格式:

在一行中输出给定字符串中包含多少个PAT。由于结果可能比较大,只输出对1000000007取余数的结果。

输入样例:

APPAPT

输出样例:

2

 分析:原先的思路是三重循环,第一遍是找“P”,找到“P”之后接着找“A”,最后找“T”;

// B40.cpp : Defines the entry point for the console application.
//

#include <iostream>
#include <string>
using namespace std;

int main()
{
	string a;
	cin >> a;
	int length = a.length();
	int num = 0;
	for (int i = 0; i < length; i++)
	{
		if (a[i] == 'P')
		{
			for (int  j = i; j < length; j++)
			{
				if (a[j] == 'A')
				{
					for (int m = j; m < length; m++)
					{
						if (a[m] == 'T')
						{
							num++;
						}
					}
				}
			}
		}
	}
	cout << num;
	system("pause");
	return 0;
}

然后,不出所料的“运行超时”

在网上找到了其他的解法:


分析:要想知道构成多少个PAT,那么遍历字符串后对于每一A,它前面的P的个数和它后面的T的个数的乘积就是能构成的PAT的个数。然后把对于每一个A的结果相加即可~~辣么就简单啦,只需要先遍历字符串数一数有多少个T~~然后每遇到一个T呢~countt–;每遇到一个P呢,countp++;然后一遇到字母A呢就countt * countp~~~把这个结果累加到result中~~~~最后输出结果就好啦~~对了别忘记要对10000000007取余哦~~~~

// B40.cpp : Defines the entry point for the console application.
//

#include <iostream>
#include <string>
using namespace std;

int main()
{
	string a;
	cin >> a;
	int length = a.length();
	int num = 0;
	int countp = 0;
	int countt = 0;
	for (int i = 0; i < length; i++)
	{
		if (a[i] == 'T')
		{
			countt++;
		}
	}
	for (int i = 0; i < length; i++)
	{
		if (a[i] == 'P')
			countp++;
		if (a[i] == 'T')
		{
			countt--;
		}
		if (a[i] == 'A')
		{
			num = (num + (countp * countt) % 1000000007) % 1000000007;
		}
	}

	cout << num;
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/piaoliangjinjin/article/details/81781407