hdu-2069(动态规划)

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23469    Accepted Submission(s): 8231

Problem Description

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

Input

The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11 26

Sample Output

4 13

Author

Lily

Source

浙江工业大学网络选拔赛

Recommend

linle   |   We have carefully selected several similar problems for you:  1171 1398 1085 1028 2152 

Statistic | Submit | Discuss | Note

心得:动态规划

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[300][120],a[10]={1,5,10,25,50};
int main(void)
{
	int n,i,j,k;
	while(~scanf("%d",&n))
	{
		memset(dp,0,sizeof(dp));
		dp[0][0]=1; //初始状态 
		for(i=0;i<5;i++) //遍历每个不同的硬币 
		{
			for(j=1;j<=100;j++) //总数不超过100 
			{
				for(k=a[i];k<=n;k++) //要求的价值 
				dp[k][j]+=dp[k-a[i]][j-1]; //状态转移方程 
			}
		}
		int res=0;
		for(i=0;i<=100;i++)
		res+=dp[n][i];
		printf("%d\n",res);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41829060/article/details/82843812