HDU 2069

hdu 2069 Coin Change(完全背包)

Coin Change

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16592 Accepted Submission(s): 5656


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 
Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 
Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 
Sample Input
11
26
 
Sample Output
4
13
 
题意:给你面值有1,5,10,25,50的币种,然后随意输入一个钱的数目,问用这些面值刚好凑成这个钱的方法有多少个(最多100个硬币)

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int dp[101][7500];
int main()
{
    int coin[5]= {1,5,10,25,50};
    int i,j,n,m,k;
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(i=0; i<5; i++)   //用的硬币
    {
        for(k=1; k<=100; k++)  //硬币数目
        {
            for(j=coin[i]; j<=7500; j++)
            {
                dp[k][j]+=dp[k-1][j-coin[i]];
            }
        }

    }
    while(~scanf("%d",&n))
    {
        int ans=0;
        for(i=0; i<=100; i++)
            ans+=dp[i][n];
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/shf1730797676/article/details/89546789